つよくなりたいなあ

地に足をつけず世界を生きぬくブログです

oculus packageを入れてエラーが出た時

なんかOVRPがないよみたいなエラーが出た時は、該当する箇所を#if !OVRPLUGIN_UNSUPPORTED_PLATFORM#endifで囲ってあげると治ると思います。

#if !OVRPLUGIN_UNSUPPORTED_PLATFORM
        if (version >= OVRP_1_15_0.version)
        {
            Result result = OVRP_1_15_0.ovrp_GetNodeFrustum2(nodeId, out frustum);
            if (result != Result.Success)
            {
                return false;
            }
            else
            {
                return true;
            }
        }
        else
    #endif
        {
            return false;
        }

公式でもエラーがでる人がいるみたい

Error when loading in Oculus Utilities for Unity — Oculus